Вторник, Декабрь 11, 2018
Software

Android 9.0 Pi не буде будет поддерживать старые приложения

В марте Google представила первую бета-версию новейшей операционной системы Android 9.0 Pi. Несмотря на ряд интересных нововведений, новая ОС наверняка разочарует поклонников ретро-софта. Все дело в том, что огромное количество приложений, написанное под старые версии Android, попросту перестанут работать сразу после выхода Android Pi.

Между тем, Google уже предупреждала разработчиков, что в новых Android будут работать не все приложения, написанные с использованием устаревших API. Правда тогда никакой конкретики не последовало, зато она появилась сейчас. Операционная система Android Pi будет требовать, чтобы приложения поддерживали API V17 и старше. Тем самым поддержки лишатся все программы, написанные для Android 4.1 и младше.

По всей вероятности, ограничения, налагаемые Google на запуск устаревшего софта, связаны с желанием Google подстегнуть разработчиков к использованию новейших инструментов, например, режима экономии энергии Doze. Главным минусом отключения поддержки устаревших API для пользователей является скорая остановка работы приложений, заброшенных создателями.

Источник

admin
the authoradmin
Тут должно быть что-то об авторе. Или не должно :)

Добавить комментарий

13 + семь =